Performance degradation and elevated error rates
Incident Report for Xray
Resolved
This incident has been resolved.
Posted Sep 03, 2019 - 23:08 WEST
Investigating
We are currently investigating this issue.
Posted Sep 03, 2019 - 22:44 WEST
This incident affected: Xray App and Xray API.