Xray Connectivity Issues

Incident Report for Xray

Resolved

A hotfix has been deployed and early monitoring indicates services are fully stabilized. We will continue to monitor to ensure full resolution.
Posted Sep 17, 2025 - 18:06 WEST

Monitoring

We have identified an issue and we have placed mitigation measures. We are moving to monitoring. If you are still seeing any underlying issue, please inform via ticket.
Posted Sep 16, 2025 - 17:35 WEST

Investigating

We are investigating connectivity issues with Xray Cloud. Our team is actively working to identify the cause and will provide updates as more information becomes available.
Posted Sep 16, 2025 - 10:05 WEST
This incident affected: Xray App and Xray API.